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Welcome! Get ready to transform your creative vision into stunning vector 
artwork!

Whether you’re illustrating, designing, or exploring 
digital art, Vexy Lines helps you turn raster images (like 
photos or bitmaps) into expressive vector designs with 
remarkable control and artistic flair.

Think of Vexy Lines as your bridge from pixel-based 
images to scalable, editable vector graphics.

What Makes Vexy 
Lines Special?

Vexy Lines offers a unique approach to vector creation, 
focusing on transforming images using sophisticated line 
and shape fills. Key features include:

•	 Expressive Line Effects: Create beautiful engraving and 
hatching effects with precise control over line density, 
direction, and style.

•	 Unique Textures: Generate patterns using text, fractals, 
and organic wave structures.

•	 Intelligent Tracing: Convert bitmap images into clean, 
scalable vector paths automatically.

•	 Customizable Style: Develop your signature look with 
highly adjustable fills, strokes, and effects.

•	 Flexible Output: Export production-ready vector files 
(SVG, PDF, EPS) and raster images (PNG, JPEG) for print, 
web, and other design applications.





Getting Started
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Getting Started This guide will walk you through everything you need to 
know to master Vexy Lines - from basic setup to advanced 
techniques. The intuitive interface makes it easy to get 
started, while powerful features give you room to grow 
and experiment.

When you first launch the application, an interactive 
Intro Tour will guide you through essential features and 
tools to help you get started. You’ll learn how to make the 
most of Vexy Lines to create your own designs.

You can always revisit this tour later by selecting Help > 
Intro Tour from the menu.

Your Creative 
Journey Begins

Ready to unleash your creativity? Let’s begin exploring 
the possibilities with Vexy Lines.

We’re excited to see what you’ll create!

Before You Begin Ensure your computer meets these system requirements:

•	 Mac: macOS 10.14 (Mojave) or newer.

•	 Windows: Windows 8.1 or later.

Memory: Minimum 4GB RAM.

Internet: Required for initial setup.
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Installation Follow these steps to download and install Vexy Lines:

1.	 Visit https://www.vexy.art.

2.	 Click the TRY FREE button and select your operating system.

3.	 Double-click the downloaded installer filed and follow the 
on-screen instructions.

4.	 After installation, launch Vexy Lines by clicking its icon in 
Applications folder.
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Activation Activate Vexy Lines upon first launch:

The activation window appears automatically, or click 
ACTIVATE in the top-right corner.

Enter the serial number from your purchase confirmation 
email. 

Click Activate to finish.

No license yet?  
Click Continue Demo to explore 
Vexy Lines in trial mode.
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Intro Tour An interactive Intro Tour starts automatically upon first 
launch:

This tour introduces essential features:

•	 Toolbar: Main tools for creating and editing.

•	 Editor Tools: Tools like Meter, Pencil, and Transform.

•	 Masking Tools: Shape and refine artwork.

•	 Layers Panel: Organize document structure.

•	 Properties Panel: Customize fills, colors, and settings.

•	 View Controls: Toggle visibility of fills and images.

Navigate the tour using Next, Back, or press X to exit. 

Access it anytime via Help > Intro Tour.
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Create Your 
First Document

1.	 Select File > New in the main menu 
 

2.	 Drag and drop your inspiration image into the window.  
 

	 Download sample images on www.vexy.art
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3.	 Adjust document size if needed.  

4.	 Click OK to start creating!
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Workspace Overview Familiarize yourself with the layout:

•	 Canvas: Your main drawing area.

•	 Tools Panel: Essential tools for vector art.

•	 Properties Panel: Adjust details of selected items.

•	 Layers Panel: Organize artwork layers.

•	 Preview Panel: Real-time artwork preview.

Navigation Tips: 

•	 Zoom: ⌘+ / ⌘- (Mac) or Ctrl+ / Ctrl- (Windows). 

•	 Pan: Hold spacebar and drag. 

•	 Reset View: Double-click the Hand tool.
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Create Your First Fill •	 A fill is a pattern of lines forming your artwork.

•	 Select Fill > New > Linear for straight lines or Wave for 
curves.

•	 Or click “+Fill” in the Layers panel. 
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Experiment with 
Fill Properties

•	 Use sliders in the Properties panel to adjust interval, 
angle, and thickness.

•	 Watch your artwork update instantly. 
 

Switch Between 
Views

•	 Use view controls to compare your vector art with the 
original image.

•	 Adjust image opacity to check progress. 
 

Save Your Work •	 Regularly save using ⌘S (Mac) or Ctrl+S (Windows).

•	 Projects save as .lines files.
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Helpful Tips •	 Start with simple images like silhouettes or outlines.

•	 Frequently use Preview mode.

•	 Experiment with different fill types.

•	 Regularly save your work, despite automatic backups.

•	 Visit our community forum for support.

Need Help? We’re here to assist:

•	 Documentation: Access via Help > User Manual.

•	 Tutorials: Beginner-friendly videos at [website].

•	 Support: Contact our team at [email].

•	 Community: Join discussions in our forum.

Ready to create something amazing? Let’s explore more 
features in the following sections!
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Interface 
Overview

Vexy Lines converts raster images into beautiful vector 
artwork. This guide introduces the main interface ele-
ments to help you start creating quickly.
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Main Canvas Your primary workspace for visualizing and editing 
artwork.

Essential Navigation

Navigate your canvas effortlessly with these shortcuts:

•	 Z: Zoom in toward cursor. 

•	 X: Zoom out. 

•	 ⌘+ / ⌘- (Mac) or Ctrl+ / Ctrl- (Windows): Quick zoom. 

•	 ⌘+2: Zoom to selected area. 

•	 ⌘+3: Fit artwork to screen. 

•	 Option/Alt + Mouse Wheel or trackpad pinch: Dynamic 
zoom adjustment.

•	 Space + Drag: Pan across canvas. 

•	 ⌘+Space: Dynamic zoom or frame zoom on specific 
areas.
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Toolbar Quick access to essential drawing and editing tools.

Editor Tools

 Editor Tool (V): Select, move, and modify objects and nodes.

 Meter Tool (R): Measure distances and angles. 

 Pencil Tool (P): Draw freehand strokes. 

 Knife Tool (K): Split and edit curves and paths. 

 Transform Tool (T): Scale, rotate, and precisely adjust objects.

Masking Tools

 Brush Tool (B): Paint masks freehand with adjustable brush 
size. 

 Rectangle Tool (I): Create rectangular masks, including per-
fect squares. 

 Ellipse Tool (O): Draw circular or oval masks. 

 Freeform Tool (S): Create custom shapes or auto-detect 
complex areas.
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Refresh Options

 Auto Refresh: Automatically update artwork as you work. 

 Refresh Fill: Quickly update the current fill. 

 Refresh All: Update all fills simultaneously.

Undo & Redo

 Undo (⌘/^+Z): Step backward through actions. 

 Redo: (⌘/^+Z) Restore previously undone actions.

Zoom Commands

 Zoom in: Magnify view for detailed editing. 

 Zoom out: Reduce magnification to view more artwork. 

 Zoom to Selected: Frame selected objects automatically. 

 Zoom to Actual Size: Display artwork at 100% scale.

View Controls

 Highlight Edges: Enhance edge visibility for easier editing. 

 Show Masks: Display mask boundaries clearly. 

 Show Fills: Toggle visibility of vector fills. 

 Show Images: Show or hide reference images.

Use commands in Window > Tool-
bar menu to display Refresh, Undo, 
and Zoom buttons.
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Panels Vexy Lines includes several panels for detailed control:

•	 Properties: Adjust fills, colors, masks, and effects precisely.

•	 Layers: Organize layers for structured and editable projects.

•	 History: Track and manage recent actions.

•	 Preview: Instantly preview artwork.

•	 Help: Contextual information about tools and features.

Menu System Access all features through logically grouped menus:

•	 File: Create, open, save, import, export

•	 Edit: Standard editing commands and preferences

•	 View: Workspace and viewing options

•	 Layer: Manage layers, groups, masks

•	 Fill: Create and modify vector fills

•	 Tools: Drawing and editing tools

•	 Window: Panel visibility and arrangement

•	 Help: Documentation, tutorials, Intro Tour

Interactive Tour Access the interactive Intro Tour anytime via Help > Intro 
Tour. This guided tour highlights key features, helping 
you quickly master the basics.





23

Document 
Structure 
Overview

Vexy Lines documents are built from several key com-
ponents that work together to create your artwork. This 
introduction explains these essential elements and how 
they interact.

Layers A layer is the building block of every document—like a 
transparent sheet where your artwork lives. Each layer 
can contain:

•	 Fills: The vector artwork itself, created in various styles.

•	 Mask: A stencil that controls which parts of your fills are visible.

•	 Mesh: An optional grid that helps reshape fills (not available for 
all fill types).

Layers are essential—every document must have at least 
one layer with fills to create exportable artwork.
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Groups Groups help organize your work by bundling layers 
together. Think of them as folders in your computer that 
can contain:

•	 Multiple layers with your artwork

•	 Other groups (sub-groups) for more organization

•	 A source image that guides your fills

Groups are especially useful for complex projects, allow-
ing you to:

•	 Toggle visibility of multiple layers at once

•	 Move related elements together

•	 Apply changes to several layers simultaneously
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Source Images Source images serve as references for your vector art-
work. They guide how your fills look but don’t appear in 
the final exported work.

How source images work:

•	 Every document has a main source image (even if  
it appears empty).

•	 Each group can have its own source image.

•	 If a group doesn’t have a source image, it uses its parent  
group’s image.

•	 You can use various file formats including PNG, JPEG, SVG,  
and PDF.

Source images help you transform raster images into 
vector art or use vector files as guides for your designs.
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How Everything 
Works Together

These components combine to create a complete Vexy Lines 
document:

•	 The simplest document may have just one layer with fills.

•	 More complex documents use groups to organize multiple layers.

•	 Source images guide how your fills appear within their respective 
groups.

•	 Masks determine which parts of the fills are visible in each layer.

Remember these basics: 

1.	 At least one layer with fills is required for a valid document. 

2.	 Groups are optional but helpful for organization. 

3.	 Source images guide your work but don’t appear in the final 
artwork. 

4.	 A layer’s mask affects all fills within that layer.

The next sections will explore each of these components 
in more detail.



Your  
First Artwork
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Create New 
Document

Creating a new document in Vexy Lines is the first step in 
bringing your vector art ideas to life. Let’s walk through 
this process step by step!

The New Document 
Dialog

1.	 Click File > New from the top menu (Shortcut: ⌘+N on macOS / 
Ctrl+N on Windows) 
 

2.	 The New Document dialog will appear, showing you:

•	 A Preview Area showing the initial state of your docu-
ment.

•	 Access to Recent Projects for quickly opening previous 
work.

•	 Settings to configure the new document’s properties.

•	 Two primary Options, selectable in the top-right corner:

Image icon: Start with a source image as a reference 
(recommended).

Empty canvas icon: Start with a blank document.
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Set Up Your 
Document

When creating a new document, you’ll need to configure a 
few settings to get started. Let’s look at the key options:

Using a Reference Image

Many Vexy Lines projects begin with a source image (like a photo 
or illustration) that serves as a guide for vector creation.

 

1.	 To add a source image:

•	 Click the Image icon (top-right) to browse and select an image file 
from your computer, OR

•	 Drag an image file from your computer directly onto the preview 
area or the Vexy Lines application icon.

•	 If you copied your image from any other image-editing app, click 
the Paste from Clipboard button in the bottom of the Preview 
Canvas to insert the image.
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2.	 The selected image appears in the preview window.

3.	 The document dimensions update automatically to match the 
image size.

You may find some royalty-free sample images at this site: 
gallery.vexy.art

Photos with clear outlines or 
silhouettes work best when you’re 
starting out. Think portraits, simple 
objects, or landscapes with distinc-
tive features.

Starting with a Blank Canvas

If you prefer to create vector artwork without a reference 
image:

 

1.	 Click the Empty canvas icon in the top-right corner of the 
dialog.

2.	 Select a Preset Size or define custom dimensions in the 
settings area.

3.	 The preview will display a blank canvas based on your chosen 
size and its dimensions.
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Choosing the 
Right Size

Vexy Lines provides standard presets to simplify setup for 
common uses:

Built-in Presets

•	 Basic: Square format, suitable for profile pictures or 
icons.

•	 3:2: Standard photographic aspect ratio.

•	 A4: International standard paper size for print.

•	 Letter: US standard paper size for print.

•	 Web: Optimized dimensions for screen and web graphics.

•	 Card: Common greeting card dimensions.

•	 HDTV: Standard 16:9 high-definition video format.
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Custom Sizes

You can also define specific dimensions:

•	 Enter values directly into the Width and Height fields.

•	 Select the desired measurement Units: Pixels (px), Milli-
meters (mm), or Inches (in).

•	 The preview updates to reflect your custom size.

Understanding Resolution (dpi)

Resolution (measured in Dots Per Inch or dpi) affects the 
detail level of the source image displayed on your can-
vas. Your final vector artwork remains perfectly scalable 
regardless of this setting.

•	 300 dpi: Recommended for high-quality print output.

•	 150 dpi: Suitable for large-format prints viewed from a 
distance.

•	 96 dpi: Standard resolution for web and screen display.

Higher dpi values provide a more 
detailed view of your source 
image but may use more system 
resources.
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Additional Features The New Document dialog includes conveniences to streamline 
your workflow:

•	 Quickly reopen projects from the Recent Projects list.

•	 Your last used settings are often remembered for faster setup.

•	 Links may be provided for accessing help resources or tutorials.

•	 An option to show or hide this dialog on startup might be available 
in Preferences.

Once your document is configured, click OK to open the work-
space and begin creating.
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Opening 
An Existing 
Document

Vexy Lines makes it easy to resume work on your saved 
projects. This section covers how to open your existing 
documents.
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Opening Saved 
Documents

You can open saved Vexy Lines (.lines) documents using 
several methods:

•	 Choose File > Open from the main menu (⌘+O on macOS 
/ ⌃+O on Windows). Then, browse to and select your file.

•	 Double-click a .lines file directly in your system’s file 
manager (Finder on macOS, File Explorer on Windows).

•	 Drag and drop a .lines file onto the Vexy Lines application 
icon or into an open Vexy Lines window.

You may find some royalty-free sample projects at this 
site: gallery.vexy.art

The .lines file format is native to 
Vexy Lines and contains all your 
project data, including layers, fills, 
masks, settings, and any embed-
ded source images.
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Accessing Recent 
Documents

To quickly reopen projects you’ve worked on recently:

1.	 Go to File > Recent Files in the main menu.

2.	 A list of your most recently opened documents will appear.

3.	 Select the desired file name from the list to open it.

4.	 You can clear this list by choosing the Clear Menu option at the 
bottom, if available.

With your document open, you’re ready to continue 
creating. The following sections explain how to add fills, 
manage layers and build your vector artwork.

An asterisk (*) next to a document’s 
name in the window title indicates 
that it has unsaved changes. If 
you attempt to close a document 
with unsaved modifications, Vexy 
Lines will prompt you to save your 
changes before closing.
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Adding A Fill In Vexy Lines, a Fill is the core mechanism that trans-
forms your source image into vector artwork. Fills 
generate patterns of vector lines or shapes based on 
the image’s details, with each fill type offering a distinct 
artistic style.

How to Add a Fill You can add a new Fill to your document in several ways:

Using the Main Menu

 

1.	 Navigate to Fill > New in the main menu bar.

2.	 A dropdown list will display the available fill types.

3.	 Select the desired fill type.

4.	 The new fill will be added to the currently selected layer (or a 
new layer if none is selected) and appear in the Layers Panel.
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Using the Layers Panel

1.	 Locate the Layers Panel (typically on the side of the work-
space).

2.	 Click the Add new fill button (marked with a + icon) at the 
bottom of the panel.

3.	 Choose the desired fill type from the pop-up menu.

4.	 The fill will be added to the selected layer in your document.
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In a New Document

If your document is currently empty:

1.	 A prompt like “Click to add your first fill” may appear in the 
Layers Panel.

2.	 Click this prompt to open the fill type selection menu.

3.	 Select a fill type to add it to a new layer.
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Overview of Fill Types Vexy Lines offers a range of fill types, each producing a 
different visual effect:

Basic Fills

 Linear: Generates straight, parallel lines. Suitable for 
clean, engraving-style effects.

 Wave: Creates parallel, wavy lines, adding a sense of 
flow or organic texture.

 Radial: Produces lines radiating from a central point, 
useful for emphasizing focus.

 Circular: Generates concentric circles, ideal for 
rounded forms or textures.

Artistic Fills

 Spiral: Creates a continuous spiral pattern originating 
from a center point.

 Halftone: Simulates traditional halftone printing 
using dots or shapes of varying size.

 Trace: Automatically detects and outlines shapes 
based on the source image’s tonal values.

 Wireframe: Generates a network of lines connecting 
points based on the image, creating a structural look.
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Expressive Fills

 Scribble: Produces lines resembling hand-drawn 
scribbles for a sketchy effect.

 Fractals: Uses fractal algorithms (like Peano curves) 
to create intricate, space-filling patterns.

 Text: Uses text characters, mapped along paths, to 
represent the image tones.

 Handmade: Allows you to draw or import custom 
vector paths to use as fill elements.

The Linear and Wave fill types are 
excellent starting points for learn-
ing how fills interact with source 
images and properties.
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Customizing Fill 
Properties

Once a fill is added, you can adjust its appearance using 
the Properties Panel:

1.	 Select the fill you want to modify by clicking its name in the 
Layers Panel.

2.	 Locate the Properties Panel (usually positioned on the right 
side of the workspace). 
 

 

3.	 The panel displays settings specific to the selected fill type.

4.	 Adjust parameters like: Interval: Controls the spacing between 
lines or elements. Angle: Sets the orientation or direction of 
the fill pattern. Thickness: Adjusts the width of the lines or 
strokes. (Other settings specific to the fill type will also be available.)

5.	 Changes are reflected on the Canvas in real-time, allowing you 
to see the immediate effect of your adjustments.
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Working with 
Fills: Key Points

•	 Start Focused: Begin by experimenting with a single fill 
type to understand its behavior and settings.

•	 Adjust Gradually: Small modifications to properties like 
interval, thickness, or angle can significantly alter the 
result.

•	 Layer Fills: Combine multiple fills on different layers (or 
sometimes the same layer) to create more complex and 
textured artwork.

•	 Reset Option: Look for reset buttons (to the right of 
manyindividual settings) in the Properties Panel to revert 
adjustments if needed.

•	 Save Variations: If you achieve a result you like, consider 
saving a version of your document (File > Save As…) 
before making further significant changes.
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Common Questions Why doesn’t my fill appear correctly? 

This can happen if the source image is very complex or 
lacks contrast. Try using a simpler image initially. Also, 
check the fill’s Interval, Thickness, and Image Thresh-
old settings in the Properties Panel, as extreme values 
can sometimes produce unexpected results.

How can I increase the detail in my artwork? 

Reducing the Interval setting generally creates more 
lines and finer detail. For outlining shapes accurately, the 
Trace fill type might be effective. Experimenting with 
Stroke Thickness linked to image tone can also add 
detail.

Is it possible to use multiple fill types in one project? 

Yes, combining different fill types, sometimes on separate 
layers, is a common technique for achieving rich and 
sophisticated vector illustrations in Vexy Lines.

Now that you understand how to 
add and customize fills, the next 
step is learning about properties 
common to most fills. The following 
sections will delve into settings 
like color, stroke appearance, and 
image interaction.
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Fill Properties When you work with Fills in Vexy Lines, the Properties 
Panel provides extensive control over their appearance 
and behavior. Fills are the core elements that generate 
vector artwork based on your source image, and their 
properties allow for precise adjustments to achieve the 
desired style.
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Fill Properties 
Overview

Each Fill type has a unique set of parameters, but many 
properties are common across different types. These 
settings control aspects like color, line appearance, inter-
action with the source image, and special effects.

Using Linear Fill as an Example

This guide uses the Linear Fill type to illustrate common 
properties. Linear Fill generates parallel straight lines, 
mimicking traditional engraving or hatching. Its versa-
tility makes it suitable for demonstrating fundamental 
concepts applicable to most fill types.

 

Key parameters for the fill include:

 Interval Sets the spacing between parallel lines. 
Smaller values create denser patterns; larger values 
create more open spacing.

 Shift Offsets the entire pattern perpendicular to the 
line direction, useful for positioning or layering fills.

 Angle Determines the orientation of the lines.

Adjusting these settings allows for 
a wide range of effects, from subtle 
shading to bold linework.
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Color Settings Fills can derive their color in two primary ways: statically 
(a single chosen color) or dynamically (based on the 
underlying source image).

Static Color

When Static Color is selected, the entire fill uses a single, 
uniform color. You can define this color using various 
tools within the color selection interface:

Color Wheel Visually select hue, saturation, and bright-
ness.

Sliders Panel Precisely define colors using RGB, HSB, or 
Grayscale values.

Box Panel Select from a grid of common colors.

Swatches Choose from predefined color palettes (e.g., 
Standard, Light, Dark, Photoshop).

Picture Panel Load an image to sample colors from it.

Pick Screen Color Sample a color from anywhere on your 
display.

System Color Dialog Access your operating system’s 
native color picker.

You can also adjust the Opacity 
of the static color to create 
semi-transparent fills.
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Dynamic Color

When Dynamic Color is enabled, the fill samples color 
information directly from the source image underneath 
it. This creates a more integrated and varied appearance, 
adapting to the image’s tones.

For fills composed of lines or curves (like Linear or Wave), 
you can control:

Color segment length Determines how frequently the 
color is sampled along the line. Shorter segments capture 
more color variation; longer segments result in smoother 
transitions.

Color segment length variation Introduces random-
ness to segment lengths, preventing overly uniform or 
mechanical patterns.

Dynamic color is often effective 
for photographic source images 
or those with rich color gradients. 
Static color may provide better 
control for graphic designs or 
illustrations requiring specific color 
palettes.



51

Image Threshold The Image Threshold setting determines which tonal 
range of the source image influences the fill’s generation 
and appearance (e.g., where lines appear or how thick 
they are). The threshold is defined on a scale from 0 (pure 
black) to 255 (pure white).

•	 The histogram visualizes the tonal distribution of your 
source image.

•	 Adjust the minimum (left slider) and maximum (right 
slider) threshold values to isolate specific brightness 
ranges.

•	 For example, setting a lower maximum value focuses 
the fill on darker areas, while adjusting both sliders can 
isolate midtones.

•	 An Inverted mode is available, useful when working with 
light-colored fills on dark backgrounds.
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Stroke Properties These properties control the visual characteristics of the 
strokes generated by the fill.

Stroke Thickness

Adjust the thickness of the fill lines or the size of elements 
in fills like Halftone.

Key controls include:

Thickness Set minimum and maximum thickness values 
using a combined slider.

Transition Mode Define how thickness varies based on 
image tone (Linear, emphasizing thicker lines, or empha-
sizing thinner lines). Smoothing Smooths out sharp 
changes in thickness along a line.

Thickness at Line Breaks Determines if thickness resets 
to minimum at line breaks or continues from the previ-
ous value.

Inverted Mode Reverses the thickness mapping, making 
lines thicker in lighter areas (useful for light-colored 
strokes).

Double-click Thickness Range to 
adjust the available range
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Dashed Lines

Create dashed or dotted line patterns instead of solid 
lines.

Parameters include:

Threshold Controls which tonal range of the image 
triggers the dashed effect.

Dash Length Set minimum and maximum lengths for the 
dashes.

Gap Length Set minimum and maximum lengths for the 
spaces between dashes.

Inverted Mode Reverses the threshold mapping, suitable 
for light-colored strokes.

Dashed lines can be used effec-
tively for textures, suggesting 
movement, or creating stylized, 
hand-drawn looks.
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Line Caps and Joins

Define the appearance of line endings (caps) and corners 
where line segments meet (joins).

Options allow customization of:

Start/End Caps Choose Flat, Round, or Triangle shapes 
for the beginning and end of lines. The Triangle cap 
includes a length parameter for adjusting sharpness.

Intermediate Caps (for Dashes) Flat or Round.

Join Style Choose Bevel (flattened corner) or Round for 
how segments connect.

Triangle caps with adjustable 
length can be particularly useful 
for rendering elements like hair or 
grass.
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Special Effects These optional effects add depth and refinement to your 
fills.

Emboss Effect

Simulates a raised (embossed) or recessed (debossed) 
appearance on the fill lines, adding a sense of dimension.

 
Height Controls the intensity of the effect (positive for 
raised, negative for recessed).

Smoothness Adjusts the softness of the transition for the 
effect.

Embossing can enhance textures, 
portraits, and graphic elements by 
adding subtle or pronounced depth.
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Smooth Mask

This property relates to the Layer’s mask, not the Fill itself, but is 
often relevant when considering the Fill’s final appearance.

When enabled on the Layer’s mask properties, Smooth 
Mask softens the mask edges, allowing for feathered 
transitions and blending between layers. Adjust Opacity 
and Feather radius for desired results.
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Transform and 
Positioning

These properties apply to the Layer or Group containing the Fill, 
affecting its overall placement and scale.

Standard transformation tools allow you to move, resize, 
rotate, and skew the selected object (Layer or Group). A 
dedicated Transform panel provides precise numerical 
control over these operations, using reference points for 
accuracy.

 
 
 
 
 
 
 

Combining Properties The true potential of Vexy Lines emerges when combin-
ing various fill properties creatively. Experimenting with 
different combinations is key to developing unique styles.

Consider combinations like:

•	 Dynamic Color + Variable Stroke Thickness + Emboss  
for nuanced portraits.

•	 Dashed Lines + Triangle Caps + specific Image Threshold 
for stylized illustrations.

•	 Static Color + Smooth Mask (on the Layer) for subtle 
background textures.

By mastering these properties, you gain fine-grained 
control over your vector artwork. Refer to specific articles 
for detailed explanations of properties unique to each Fill 
type.
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Adding A Mask In Vexy Lines, a Mask controls the visibility of the Fills 
within a Layer. It acts like a stencil, defining precisely 
where the artwork on that layer appears or is hidden. 
Each Layer can have one mask associated with it.
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How to Add a Mask To add or modify a mask for a specific Layer:

1.	 Select the target Layer in the Layers Panel.

2.	 Choose one of the mask creation tools from the Toolbar:  
 

 Brush (B): Paint mask areas freehand.  
 

 Rectangle (I): Define rectangular mask areas. 
 

 Ellipse (O): Define elliptical or circular mask areas.  
 

 Freeform (S): Draw custom mask shapes.

3.	 Use the selected tool on the Canvas to define the mask area.
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Mask Creation 
Methods

Masks can be created using two primary approaches:

•	 Manual Drawing: Use the Brush, Rectangle, Ellipse, or 
Freeform tools to draw shapes directly, defining the 
visible areas.

•	 Auto-Detection (Shape Tools): The Rectangle, Ellipse, 
and Freeform tools include an intelligent auto-detection 
feature. Clicking on distinct shapes or tonal areas in your 
source image will automatically generate a corresponding 
mask shape.

Using Auto-Detection Modifiers:

When using the auto-detection feature of the Rectangle, 
Ellipse, or Freeform tools:

•	 Click: Detects a shape and adds it to the existing mask 
area.

•	 Alt+Click (or ⌥Option+Click on macOS): Detects a shape 
and subtracts it from the existing mask area.

The following sections provide detailed instructions on 
using each specific mask creation tool effectively.
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Mask Editing Vexy Lines provides several tools specifically designed 
for creating and refining masks. Masks define the visible 
areas of a layer’s fills, acting like stencils. Understanding 
each tool helps you achieve precise control over your 
artwork.

Brush Tool (B)  Ideal for freehand mask painting and detailed adjust-
ments.

When the Brush tool is active, additional controls appear 
in the Toolbar allowing you to switch between adding to 
the mask (painting white) and removing from the mask 
(painting black/erasing).

 

Paint Mask (Add Mode) 

With the “Add” mode selected, click and drag to paint 
white areas onto the mask, revealing the layer’s content 
where you paint.

Erase Mask (Remove Mode) 

Select the “Remove” mode in the Toolbar, then click and 
drag to paint black areas, concealing the layer’s content. 
> Alternatively, you can quickly erase while in Add mode by 
holding down Alt (Windows) or ⌥Option (macOS) as you 
drag.
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Draw Straight Lines 

Hold ⇧Shift and click between two points to create a 
straight brush stroke segment on the mask. Dragging 
with ⇧Shift held down constrains painting to perfectly 
horizontal or vertical directions.

Adjust Brush Size

Modify the Size value in the Brush tool’s options within 
the Toolbar. - Interactively resize the brush cursor by 
holding Ctrl and dragging the mouse
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Rectangle Tool (I)  Efficient for creating rectangular or square mask 
areas.

Draw Rectangle Click and drag to add new rectangular 
area to the mask.

Draw Square Hold ⇧Shift while dragging to constrain 
the shape to a perfect square.

Draw from Center Hold Alt (or ⌥Option) while dragging 
to draw the rectangle outwards from the starting click 
point.

Auto-Detect Click once on a distinct rectangular shape 
in the source image to attempt automatic mask creation 
(replaces current mask).

Subtract from Mask Hold Alt (or ⌥Option) and click 
(auto-detect) or drag to remove a rectangular area from 
the existing mask.
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Ellipse Tool (O)  Suitable for creating elliptical or circular mask areas.

Draw Ellipse Click and drag to add an elliptical area to 
the mask.

Draw Circle Hold ⇧Shift while dragging to constrain the 
shape to a perfect circle.

Draw from Center Hold Alt (or ⌥Option) while dragging 
to draw the ellipse outwards from the starting click point.

Auto-Detect Click once on a distinct circular or elliptical 
shape in the source image to attempt automatic mask 
creation (replaces current mask).

Subtract from Mask Hold Alt (or ⌥Option) and click 
(auto-detect) or drag to remove an elliptical area from the 
existing mask.
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Freeform Tool (S)  Best for drawing custom mask shapes or tracing 
complex contours.

Draw Custom Shape Click and drag to draw a freehand 
shape and add it to the mask. The shape closes automati-
cally when you release the mouse button.

Auto-Detect Click once on a distinct object or area in 
the source image to attempt automatic shape detection 
(replaces current mask).

Subtract from Mask Hold Alt (or ⌥Option) and click 
(auto-detect) or drag to remove a custom shape from the 
existing mask.
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Edit Tool (V)  Provides precise vector editing capabilities for mask 
contours and nodes (points).

Working with Mask Contours (Paths)

Select Contour Click directly on a mask contour line to 
select it.

Select Multiple Contours Hold ⇧Shift while clicking to 
select additional contours.

Select All Contours Use ⌘+A (macOS) or Ctrl+A (Win-
dows) when the Edit tool is active and focused on the 
mask.

Move Contours Drag selected contours to reposition 
them on the canvas.
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Editing Nodes (Points on Contours)

Select Node Click on a node (square or circle point on the 
contour) to select it.

Select Multiple Nodes

•	 Hold ⇧Shift while clicking nodes.

•	 Click and drag a rectangular selection box around the 
desired nodes.

•	 Hold Alt (or ⌘Option) and drag to draw a freeform lasso 
selection around nodes.

Select All Nodes on Contour Select a contour first, then 
use ⌘+A (macOS) or Ctrl+A (Windows).

Adjust Shape Drag selected nodes to modify the contour’s 
shape. Bezier handles may appear for adjusting curve 
segments (drag the handles to change curvature).
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Mask Editing Tips •	 Improve Visibility: Temporarily hide the layer’s fills 
(using the Show Fills toggle in the toolbar or View menu) 
to see the mask contours more clearly during editing.

•	 Use Highlights: Ensure Highlight Edges or Show Masks 
options are enabled in the view controls (toolbar or View 
menu) to better visualize selected contours and nodes.

•	 Combine Tools: Use different tools for different tasks 
(e.g., Freeform for initial shape, Edit tool for refinement).

•	 Remember Function: White areas of the mask reveal the 
fill; black areas hide it.

Further sections will discuss advanced mask properties 
and techniques for refining mask appearance and behav-
ior.
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Mask Properties Masks control the visibility of Fills within a Layer. Vexy 
Lines provides several options in the Properties Panel to 
refine how your masks look and behave.

To access these settings, select the Layer containing the 
mask in the Layers Panel, then locate and expand the 
MASK section in the Properties Panel.
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Invert  This option instantly reverses the mask, swapping the 
visible and hiddenareas. It’s useful for quickly creating 
negative space effects or inverting complex mask shapes 
without needing to redraw them.

Smooth Mode Enable Smooth mode to activate properties for creating 
soft-edged, blended mask effects. This mode differs from 
the default sharp-edged vector masks and allows for 
feathered transitions and transparency. Keep Smooth 
Mode disabled if you need crisp, precise vector edges.

Opacity (Requires Smooth Mode)

 When Smooth Mode is active, Opacity controls the 
overall transparency of the mask effect. Adjust this 
setting to blend layers naturally, create subtle overlays, 
or make the masked area partially see-through. Lower 
values increase transparency.

Feather (Requires Smooth Mode)

 Also available only in Smooth Mode, Feather softens 
the mask’s edges by blurring the boundary over a speci-
fied distance (radius). Use higher values to create gentle, 
gradual transitions, perfect for natural-looking blends, 
vignettes, or soft-focus effects at the mask edge.
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Modify This section offers tools to adjust the shape or edge of 
your vector mask without redrawing it entirely.

Expand / Contract

 Use this property to uniformly resize the mask 
boundary. Enter a positive value to Expand the mask 
area outward, or a negative value to Contract (shrink) it 
inward. This is useful for fine-tuning the overall coverage 
or creating consistent offsets.

Edge to Stroke

 This converts the mask’s boundary line into a visible 
stroke effect centered along the edge. You can typically 
adjust the width of this generated stroke, allowing you to 
create outlines around masked shapes or generate border 
elements based on the mask.

Note: Remember that Opacity and Feather require 
Smooth Mode to be enabled. For standard, sharp-edged 
vector masks, leave Smooth Mode disabled.
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Units of 
Measurement

Vexy Lines allows you to work with different units of 
measurement depending on your project’s requirements.

You can choose from:

•	 Pixels (px): Ideal for screen-based design (web graphics, 
UI elements).

•	 Millimeters (mm): Commonly used for print design, 
especially with metric standards (e.g., A4 paper).

•	 Inches (in): Used for print design, particularly with US 
standards (e.g., Letter paper).

•	 Points (pt): Often used in typography and print design (1 
point = 1/72 inch).
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Where Units 
Are Applied

The selected unit of measurement affects various parts of 
the Vexy Lines interface and workflow:

•	 Parameter Input: Values for properties like size, position, 
stroke thickness, and fill intervals are entered and dis-
played in the chosen unit.

•	 Rulers: If visible, the workspace rulers display incre-
ments based on the selected unit, aiding alignment.  
 

•	 Meter Tool: Measurements taken with the Meter tool are 
reported in the selected unit. 
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Changing the Unit 
of Measurement

You can change the active unit for your current document 
easily:

1.	 Open the Properties Panel.

2.	 Scroll to locate the VIEW section (at the bottom of the proper-
ties list).

3.	 Find the Units setting (or similar label).

4.	 Select your desired unit from the dropdown menu.  
 

The interface elements and relevant property values will 
update immediately to reflect the newly selected unit.
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Adding A Layer Layers are fundamental organizational tools in Vexy 
Lines, acting like transparent sheets stacked on top of 
each other. Each layer serves as a container for parts of 
your artwork, holding the Fills that create the visuals and 
optionally a Mask to control visibility. Using layers helps 
you manage complex designs, work on elements inde-
pendently, and control the stacking order of your artwork.

A single layer typically contains:

•	 Fills: One or more Fill objects that generate the vector 
artwork.

•	 Mask: An optional mask defining which parts of the 
layer’s Fills are visible.

•	 Mesh: An optional grid used for distorting the layer’s Fills 
(not applicable to all Fill types, e.g., Trace, Handmade).
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When to Use 
New Layers

Creating new layers is beneficial when you need to:

•	 Apply different Fill types or styles to distinct parts of your 
design (e.g., separate layers for skin, hair, and clothing in 
a portrait).

•	 Isolate elements for easier editing without affecting other 
parts of the artwork.

•	 Organize complex compositions logically.

•	 Control the front-to-back arrangement of overlapping 
elements.

Adding a New Layer You can add a new layer to your document using these 
methods:

 

•	 Click the Add New Layer button (icon: ) in the Layers 
Panel.

•	 Choose Layer > New > Layer from the main menu.

•	 If the document is empty, adding the first Fill will auto-
matically create a new layer to contain it.

The new layer will appear in the Layers Panel. You can 
double-click its default name (e.g., “Layer 1”) to rename 
it descriptively.
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Managing Layers The Layers Panel provides controls for managing indi-
vidual layers:

Visibility

•	 Click the Eye icon ( ) next to a layer’s name to toggle its 
visibility on the Canvas.

•	 Hiding layers helps you focus on specific parts of your 
design.

•	 Hidden layers are typically excluded from final exports.

Selection

•	 Click on a layer’s name or row in the Layers Panel to 
select it. 
 

•	 The selected layer is usually highlighted.

•	 Many tools and properties only affect the currently 
selected layer.
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Arrangement (Stacking Order)

•	 Click and drag a layer up or down within the Layers 
Panel list to change its stacking position. 
 

•	 Layers higher in the list appear in front of layers lower in 
the list on the Canvas.

•	 Use arrangement to control how elements overlap in your 
artwork.

Since each layer functions independently, you can freely 
experiment with Fills, Masks, and properties on one layer 
without altering the content of others.
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Sources And 
Groups

As your projects become more complex, Groups provide 
a powerful way to organize your document structure in 
Vexy Lines. Similar to folders on your computer, Groups 
act as containers that can hold multiple Layers, other 
Groups (creating nested structures or sub-groups), and 
even their own dedicated Source Image.

Using Groups helps keep your Layers Panel tidy and 
allows you to manage related parts of your artwork collec-
tively.
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Creating Groups There are several ways to create a Group:

•	 Click the New Group button  in the Layers Panel.

•	 Choose Layer > New > Group from the main menu.

•	 Select one or more Layers or existing Groups in the 
Layers Panel and use the shortcut ⌘ + G (macOS) or Ctrl + 
G (Windows).

Using Source Images 
with Groups

A key feature of Groups is that each can have its own 
Source Image. This image serves as the reference for cal-
culating Fill properties (like dynamic color or thickness 
variations) for all Layers contained within that Group and 
its sub-groups.

•	 Purpose: Source Images guide the appearance of Fills but 
are not part of the final exported artwork.

•	 File Types: You can use standard raster images (PNG, 
JPEG, TIFF) or vector files (SVG, PDF) as Source Images.

e 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
xists) is used. 
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Adding and 
Managing Source 
Images in Groups

You can assign or change a Group’s Source Image using 
these methods:

Via Menu:

1.	 Select the target Group in the Layers Panel.

2.	 Choose Layer > Add Source (to add) or Layer > Replace 
Source (to replace).

3.	 Select your desired image file.

4.	 An interface may appear allowing you to position and scale the 
image relative to the document canvas. Adjust as needed and 
press ⏎ Enter to confirm.



86

Via Drag and Drop:

1.	 Drag an image file from your computer directly onto the Vexy 
Lines application window.

2.	 A dialog will appear. Choose an option like Add as Source to 
New Group or Add/Replace Source in Selected Group.

3.	 Position and scale the image if prompted, then press ⏎ Enter.

Managing Existing Source Images:

•	 Select: Click the small image icon next to the Group name 
in the Layers Panel to select the Source Image itself.

•	 Transform: Once selected, you can usually resize or 
reposition the Source Image on the canvas using standard 
transform controls.

•	 Remove: With the Source Image selected (by clicking its 
icon in the Layers Panel), press the Delete or Backspace 
key, or use the Delete button in the Layers Panel.
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Organizational 
Benefits of Groups

Beyond managing Source Images, Groups enhance proj-
ect organization:

•	 Hierarchy: Nest Groups within other Groups to create 
logical structures for complex designs (e.g., a “Character” 
group containing “Head” and “Body” sub-groups).

•	 Visibility Control: Toggle the visibility of an entire Group 
(and all its contents) using the Eye icon in the Layers 
Panel.

•	 Bulk Operations: Select a Group to apply transforma-
tions (move, scale, rotate) or other actions to all contained 
Layers simultaneously.

•	 Easy Reordering: Drag and drop Layers or sub-groups 
into or out of different parent Groups in the Layers Panel.

Effectively using Groups and their associated Source 
Images is crucial for maintaining clarity and efficiency in 
complex Vexy Lines projects.

Document View Options

Vexy Lines provides several options to customize how 
your document and artwork are displayed during the 
creation process. Adjusting these settings can help you 
focus on specific elements, improve editing accuracy, and 
tailor the workspace to your preference.
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Toolbar View Controls The main Toolbar includes quick-access buttons to toggle 
the visibility of key elements:

 Highlight Edges When enabled, enhances the visibil-
ity of selected Fills or Mask contours, making them easier 
to identify and edit.

 Show Masks Toggles the visibility of Mask boundaries 
and Mesh grid lines on the Canvas.

 Show Fills Toggles the visibility of all generated Fill 
artwork on the Canvas. Turn this off to focus solely on 
Masks or Source Images.

 Show Source Toggles the visibility of any Source 
Images associated with the document or active Group.

View Menu The View option in the main menu bar provides access to 
a broader range of display settings, including:

•	 Zoom level controls and navigation commands.

•	 Options to show or hide specific user interface panels 
(like Properties, Layers, etc.).

•	 Settings for the workspace background color.

•	 Manual refresh commands and rendering quality options 
(if applicable).
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Properties Panel 
(View Section)

The Properties Panel contains a dedicated VIEW section 
offering more granular control over display elements:

Source Image Opacity

Adjust the transparency level of the visible Source Image.

Visual Highlights

Customize the colors used to highlight selected Fill edges 
and Mask boundaries for better visibility against your 
artwork.

Background Color

Set a custom background color for the canvas area, which 
can be helpful for contrast when working with specific 
image or fill colors.

Remember that all view settings 
other than Background Color only 
affect the display while you are 
working in Vexy Lines. They do not 
alter the content or appearance of 
your final exported files.
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Saving Your 
Work

Regularly saving your Vexy Lines project is crucial to pre-
vent losing progress. While Vexy Lines includes auto-save 
features for protection against unexpected interruptions, 
frequent manual saving remains the best practice.

Standard Saving Vexy Lines saves projects in its native .lines file format. 
This format preserves all your document information, 
including layers, groups, fills, masks, settings, and source 
images.

•	 Save: To save your current changes, choose File > Save 
from the main menu, or use the keyboard shortcut (⌘+S 
on macOS / Ctrl+S on Windows).

•	 Save As: To save a new version of your project under a 
different name or location, choose File > Save As…, or 
use shortcut (⌘+⇧+S on macOS / Ctrl+Shift+S on Win-
dows).

When saving a document for the first time, you will be 
prompted to enter a filename and select a location on 
your computer.
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Automatic Safety 
Features

Vexy Lines incorporates features designed to help protect 
your work automatically:

Auto Save

Periodically, Vexy Lines automatically saves a temporary 
recovery file in the background. If the application closes 
unexpectedly (due to a crash or power outage), it will 
attempt to recover your work from this file the next time 
you launch it. You can enable this feature and configure 
the saving interval in Preferences > Autosave.

Backup Copies

When enabled, Vexy Lines creates a backup copy of the 
previous version each time you manually save your docu-
ment. These backup files usually have a .~lines extension 
(or similar) and are stored alongside your original project 
file. This provides a way to revert to an earlier saved state 
if needed. This feature can usually be toggled on or off in 
Preferences > Save.

While auto-save and backups 
provide a safety net, manually 
saving your work frequently using 
File > Save (⌘/Ctrl+S) is the most 
reliable way to ensure your latest 
changes are preserved, especially 
before making significant edits or 
closing the application.
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Exporting The 
Artwork

When your project is complete, you can export it into 
various file formats suitable for use in other applications, 
printing, web display, or further editing. Vexy Lines offers 
options for exporting both scalable vector graphics and 
fixed-size raster images.
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Vector Export Vector formats preserve the mathematical descriptions 
of your artwork, allowing it to be scaled infinitely with-
out losing quality. They are ideal for logos, illustrations 
intended for print, and designs that may need resizing.

Common vector export formats include:

•	 SVG (Scalable Vector Graphics): A widely supported 
standard for web graphics and interoperability between 
vector editing applications.

•	 PDF (Portable Document Format): Excellent for sharing 
documents and high-quality printing, preserving vector 
data and layout.

•	 EPS (Encapsulated PostScript): A legacy format often 
used in professional print workflows.
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Vector Export Options When exporting to vector formats (SVG, PDF, EPS), Vexy 
Lines provides options to control how the document 
structure is saved in the output file. Select the option that 
best fits your intended use:

Export Layers Separately

This option preserves the layer structure from your Vexy 
Lines document within the exported file, representing 
layers as native layers or groups where the format sup-
ports it (e.g., SVG). Select this when you need to maintain 
layer organization for continued editing in other vector 
software (like Adobe Illustrator, Affinity Designer, Ink-
scape). If this option is off, Vexy Lines will combine all 
visible layers into a single layer or group in the exported 
file. The visual appearance is maintained, but the original 
Vexy Lines layer structure is discarded. Choose this for 
final delivery or when layer separation is not required in 
the destination application.

Combine layers with the same color

This option organizes the exported artwork based on 
shared colors, grouping all elements of the same color 
together. This method is specifically designed for work-
flows requiring color separation, such as screen printing 
or vinyl cutting.

The availability and specific behav-
ior of these export options depend 
on the capabilities of the chosen 
vector format (SVG, PDF, or EPS). 
Review the settings during the 
export process to ensure the output 
matches your requirements.
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Raster Export Raster (or bitmap) formats represent artwork as a grid 
of pixels. They are suitable for web images, photographs, 
and situations where scalability is not the primary con-
cern. Common raster export formats include:

•	 PNG (Portable Network Graphics): Loseless format 
which supports transparency, making it ideal for web 
graphics or overlays.

•	 JPEG (Joint Photographic Experts Group): Offers good 
compression for smaller file sizes, suitable for photo-
graphs on the web (does not support transparency).

Raster Export Options

When exporting to raster formats, you can control:

•	 Dimensions: Set the exact width and height in pixels.

•	 Color Mode: Choose between color or grayscale output.

•	 Transparency: Configure transparency options for 
formats like PNG.

•	 Background Color: Select a background color if transpar-
ency is not used or supported.
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The Export Process To export your artwork:

1.	 Choose File > Export from the main menu.

2.	 In the export dialog, choose whether you need vector or raster 
result and select the desired output Format (e.g., SVG, PNG, 
PDF, PNG or JPG).

3.	 Configure any available Export Settings specific to the chosen 
format (e.g., dimensions, layer handling, quality).

4.	 Choose a Destination folder and enter a Filename for the 
exported file.

5.	 Click Export to generate the file.

Exporting functionality requires an 
activated, licensed version of Vexy 
Lines. Trial or demo versions may 
allow you to preview export options 
but might restrict saving the final 
output files.
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Clipboard Operations For quick transfers to other vector editing applica		
tions (like Adobe Illustrator or Affinity Designer), Vexy 
Lines may support copying artwork directly to the system 
clipboard.

•	 Select the desired elements or layers in Vexy Lines.

•	 Use the Edit > Copy command (⌘Cmd/⌃Ctrl + C).

•	 Switch to the other application and use its Paste com-
mand (⌘/Ctrl + V).

This method often preserves the vector nature of the 
artwork, allowing for further editing in the destination 
application. Compatibility may vary depending on the 
applications involved.
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Vexy Lines User Manual 
 
 
Vexy Lines offers a unique approach to vector 
creation, focusing on transforming images using 
sophisticated line and shape fills. Key features 
include:

•	Expressive Line Effects: Create beautiful engraving 
and hatching effects with precise control over line 
density, direction, and style.

•	Unique Textures: Generate patterns using text, 
fractals, and organic wave structures.

•	Intelligent Tracing: Convert bitmap images into 
clean, scalable vector paths automatically.

•	Customizable Style: Develop your signature look 
with highly adjustable fills, strokes, and effects.

•	Flexible Output: Export production-ready vector 
files (SVG, PDF, EPS) and raster images (PNG, JPEG) 
for print, web, and other design applications.

www.vexy.art


